welcome to the new iphone-develoeprs community. Register below to get started.

XDA Users Click Here New Users Click Here
+ Reply to Thread
Results 1 to 3 of 3

Thread: HTTP 504 error on T-Mobile EDGE network?

  1. #1
    Junior Member
    Join Date
    Oct 2012
    Posts
    2

    HTTP 504 error on T-Mobile EDGE network?

    Hi,

    I have what is hopefully an easy to answer question regarding how cellular data works on the iphone. I recently switched my iphone4 (GSM) from AT&T to T-Mobile. I've configured the APN and data profiles per their support site (support.t-mobile.com/docs/DOC-2383).

    I have tried the following APN values:

    epc.tmobile.com
    wap.voicestream.com
    internet2.voicestream.com (this last one I'm using currently)
    The reason I'm posting here is that the behavior I am seeing in Safari is after a few slow web requests, I get HTTP ERROR: 504 -Gateway Timeout. Is this an issue with the APN being slow, or is this a local proxy on the iPhone that's timing out the connection?

    I was hoping to get ~100kbps on EDGE at least, but this feels more like 2400bps (full signal of course).

    Thanks,
    -saarp

  2. #2
    Member
    Join Date
    Sep 2012
    Posts
    50
    Thats the wrong apn and yes the edge network sucks ass. I dont think the apn has anything to do with your browser issues I may be wrong though

  3. #3
    Junior Member
    Join Date
    Oct 2012
    Posts
    2
    Still, can't help wondering if there is something else that's not configured right. Certain kinds of text-based data access is generally very quick (gmail, one bus away). As soon as I hit a jpeg everything seems to bog down.

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts