Hi there.

Thanks for the new redsnow 0.9.15b1 I have an iphone 3GS new bootrom, which was connected to itunes and updated to iphone ios6.

I wanted to jailbreak and unlock from carrier orange and install cydia.
So I used the latest redsnow 0.9.15b1 from devteam and I jailbroke my iphone3GS successfully with cydia installed.I was so pleased that i decided i wanted to unlock from orange immediately, i also knew i couldnt unlock my updated iphone 3GS which was on ios6 and on baseband 5.16.07, unless i downgraded to 5.1.1 and lower baseband.

To unlock i decided to downgrade to firmware iphone 2,1_5.1.1_9B206 so i stitched the saved blobs to the downloaded iphone 2,1_5.1.1_9B206 firmware and tried restoring my iphone 3GS using the latest redsnow 15b1 with baseband downgrade checked. During the unpacking stage of the software, the redsnow gave an error message and then quickly dissapeared and then my iphone was now stuck in a loop displaying recover using itunes.

I disconnected then reconnected to pc and tried the recovery fix on redsnow and again i was getting the same loop itunes recover using usb on the display. Ive tried switching off and putting it in dfu mode using redsnow and following instructions holding home button down etc, but it wont reboot or recover it goes into reconnect to itunes recovery loop then i receive message from redsnow stating i need to google or seek help.

i then decided that maybe the iphone current software may have been corrupted in trying to downgrade and that maybe i should connect back to itunes to reinstall the current itunes apple software on my iphone 3Gs to io6. So I tried to restore back to ios 6 using itunes,the itunes then came back after unloading the software and installing and then whilst trying to verify came back with error code 3194. So i tried again taking out the reference to apples url in the hosts file, but to no satisfaction. Then my iphone reboot and then came back with the same you must recover using itunes display loop.

So I tried to fix this recovery problem using latest tinyumbrella but even tho the iphone is connected, the tinyumbrella software is showing the phone as disconnected and is also coming up with some unusual phone identifcation nos on the left hand pane of the software, and im unable to access the recovery fix button, because they are greyed out. So again i tried recovery using redsnow, but again no repair.

Ive also queried the identity of 3gs using redsnow and this come up with Based on the last time this iPhone 3GS connected in DFU mode:

CPID: 8920 CPRV: 15 CPFM: 03 SCEP: 03 BDID: 00 ECID: 0000031F2116FD75 SRTG: [iBoot-359.3.2] -- NEW BOOTROM

So i need help from someoune out there more experienced than i am.

Help me please get my iphone up and running..

Thanks in advance.