-Iphone 4
-BB 4.10.01
-Gevey sim
-IOS 5.0.1

Hello iphone community. I plan to update my iphone 4 to ios 6 but I use gevey sim(which only support ios 5.0.1). Is it possible to run on ios6 and use gevey sim?
I read that it will work if I preserve my baseband. Need infos. Thanks!